Probleme mit facebook-Like-Button (springt zurück und zeigt Beiträge nicht auf der Pinnwand an) gelöst: so geht es wieder!

Vor ein paar Tagen schrieb ich über dieses Problem mit dem facebook-Like-Button, der einfach nicht funktionierte. Ich hatta da unendlich viel Zeit und Energie geopfert, sogar andere Menschen da mit reingezogen (sorry nochmal, Dansen! :)) – es gab einfach keine Lösung. Im Laufe der letzten zwei Wochen haben sich dann immer mehr Kommentatoren in genau derselben Problematik bei mir gemeldet, es ging offensichtlich Allen gleich – das Problem lag also nicht an den Blogs, sondern an facebook. Jetzt gibt es endlich eine Lösung, der Held des Tages ist Tim, der mir Folgendes in die Kommentare schrieb:

Ich hatte heute auf einzelnen Seiten das selbe Problem und habe nach ein bißchen herumprobieren herausgefunden, dass es sich möglicherweise um eine fehlerhafte Zwischenspeicherung der Seiteninformationen bei FB handelt.

Lösung:
Die URL der jeweiligen Seite über den FB Linter (http://developers.facebook.com/tools/lint/) neu indizieren lassen, Seite neu laden und schon klappt’s auch wieder mit dem Like-Button :)

Und ja – es funktioniert, I doublechecked! Es ist jetzt vielleicht etwas umständlich, nach jedem Posting die URL neu zu „linten“ – aber es hilft. Vielleicht ist es ja auch nur ein vorübergehendes Problem bei facebook, mal sehen. Solange wird ge-linted, hilft ja nichts. Danke, Tim!

Kommentare

10 Antworten zu “Probleme mit facebook-Like-Button (springt zurück und zeigt Beiträge nicht auf der Pinnwand an) gelöst: so geht es wieder!”

  1. Phil sagt:

    Tja Herr Winkelsen, aber das Problem ist doch, dass diese Fehlfunktion doch sicher nicht nur auf einer Seite auftritt: Willst du nun alle Seiten manuell durch den Linter jagen? Dann schreib lieber weiter Einträge ;-)

    Oder hast du ne kreative Idee?

  2. MC Winkel sagt:

    @Moody: DEN HATTE ICH DOCH GESEHEN, MOODY! :) Aber ich hatte doch keine Ahnung, dass man da dann jede einzelne, neue + nicht funktionierende URL einmal „durchlinten“ lassen müsste. Hätteste das mal dazu geschrieben, Mensch! :) @Phil: Wie meinst Du „Seiten“? Es reicht ja, die URL, für die der Button nicht funktioniert, einmal „durchzulinten“. Soviel Zeit muss dann wohl sein, dauert je Posting 5 Sekunden! :)

  3. Perot sagt:

    „Linten“? Wat is denn dette?

  4. Moody sagt:

    @MC Winkel: mea culpa – allerdings muss ich das bei mir auch gar nicht bei jedem link machen. halt nur die, die so gar nicht wollen

  5. Dansen sagt:

    Fukc! DAS ist zu einfach ;-)

    … aber gut zu wissen….

  6. Matthias sagt:

    Wo kann ich da was neu indizieren lassen? Oder geschieht das automatisch nach Eingabe des Links?

  7. Phil sagt:

    Tag Herr Winkelsen,

    mein Problem ist eher, dass bei mir die gesamte Seite (nicht einzelne Beiträge, ALLES!) nicht funktioniert – ich könnte nun jede URL durch den Linter jagen, stimmt.

    Aber will ich das? ;-)

  8. So, nachdem ich ja „u know“ Kontakt zu FB aufgenommen hatte und eine „Techie“ Lösung via OGP.me angeboten bekommen hatte, kommt hier wohl die Lösung für Euch WordPressler : http://www.emanuel-kluge.de/html-css/facebook-like-button-per-xfbml-in-wordpress-blogs-einfugen/

    Der FB Admin und die Anwendungs ID muss in die Meta eingepflegt werden.
    Sollte es funzen seid mir für ewig dankbar und schliesst mich in Eure „blogroll“ ein ;)

  9. Moody sagt:

    @Jaycee aus dem Atomlabor Wuppertal: hab ich schon seit längerem eingebaut – hilft nicht wirklich

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.